Check out new solution for ISP:
Splynx Isp Framework solution for ISP with Radius and Mikrotik API support


Mikrobill + PPOE authentication

  1. 4 years ago

    Hi support, i have just install mkrobill demo version, i want to test it with ppoe authentication. But when i tried to add the router i always have in the log connection errors.
    i follow the instructions in the tutorial but till the same thing.
    Need your help.

  2. Mikrobill_Alex

    Dec 2013 Administrator

    Hi, do you use Radius of Mikrobill ?

  3. yes, when i use PPP(Secrets) everything is ok, biut when i use PPP (Radius), in the mikrotik log i have authentication failure radius timeout.

  4. Mikrobill_Alex

    Dec 2013 Administrator

    It looks that something is wrong in settings of router - for example IP of Radius, password between radius and Mikrobill...

  5. I have verified,everything is ok. i tried it with another radius server (usemanager of mikrotik) and it is working well, it seems like freeradius daemon is not working on the server.

  6. Mikrobill_Alex

    Dec 2013 Administrator

    and daemon is running or not ?
    Try to run these commands and write result :
    service freeradius restart
    service mikrobill_radd restart

  7. when i run service freeradius restart i have no result, no output
    when i run service mikrobill_radd restart this is the output:

    • Stopping MikroBill Radius Daemon mikrobill_radd.php
    • Starting MikroBill Radius Daemon mikrobill_radd.php
  8. admin

    Dec 2013 Administrator
    Edited 4 years ago by admin

    try to run freeradius in debug mode ...

    freeradius -Xxxxx

    and write result here...

  9. attached to this post the output of freeradius -Xxxxx
    and the output freeradius restart:
    * Stopping FreeRADIUS daemon freeradius

    * /var/run/freeradius/freeradius.pid not found...
    [ok]

    * Starting FreeRADIUS daemon freeradius

    /usr/sbin/freeradius: symbol lookup error: /usr/lib/perl/5.14/auto/IO/IO.SO:

    undefined symbol: Perl_xs_apiversion_bootcheck [fail]

    Attachments

  10. admin

    Dec 2013 Administrator
    Edited 4 years ago by admin

    ha, it's bug in perl versions ...

    make:

    ls -l /usr/lib/perl

    to get perl version...
    exec:

    export LD_PRELOAD="/usr/lib/libperl.so.{perl_version}"

    don't remember to change {perl_version}
    and after run:

    freeradius -Xxxx

    when all will be ok:
    add

    export LD_PRELOAD="/usr/lib/libperl.so.{perl_version}"

    to /etc/init.d/freeradius
    after
    export $PATH ...

  11. i did exactly what you ask, everything is ok now with the freeradius daemon but customer can't authenticate and in the mikrotik log i have "authentication failed, radius timeout"

  12. admin

    Dec 2013 Administrator

    check, radius secret , server ip

    if all ok, please send output of

    freeradius -Xxxxx
  13. I followed the whole procedure from the top and is the result of my command freeradius-Xxxxx and my file radius.conf

  14. admin

    Dec 2013 Administrator

    if you see message :)

    Thu Dec 12 12:56:10 2013 : Error: /etc/freeradius/radiusd.conf[240]: Error binding to port for 0.0.0.0 port 1812

    why you not stop radius server and not try again ???????

  15. Mikrobill_Alex

    Dec 2013 Administrator

    Guys, can you send me email and I will find the problem in 5 minutes ? Mail is - alex@mikrobill.com

  16. 3 years ago

    hello,

    I install debian as you had asked me in the mall. Freeradius is installed and it booted fine. When connecting the logs say mikrotik user Username authentication failed - radius timeout. addresses and secret are configured

  17. 2 years ago

    centroserviciosaccion@gmail.com
    buenas tardes, este es mi correo me interesa saber si el proyecto de mirkrobill todavia sigue porque a mi me interesa una licencia de mas capacidad de 100 clientes y me quiero saber si se le puede instalar el modulo de pppoe para los clientes te dejo mi correo contesteme lo mas rapido posible, gracias.

  18. estamos jodidos !!

or to reply!